Partie V. GNS3 Réseau n° 3
Précédent ACCUEIL Suivant

V. GNS3 RÉSEAU N° 3

Vous allez créer un réseau constitué de deux routeurs 3600 équipé, chacun, d'un module "NM-16ESW" ; les routeurs seront ensuite configurés avec deux "VLan" (VLan 10 et VLan 20) ; des ordinateurs "VPCS" complèteront la topologie pour les tests de fonctionnement.

5.1 - Ajouter un module dans un routeur 3600

Lancez le logiciel GNS3.

Reprenez le tutoriel "GNS3 RÉSEAU N° 1" pour créer le nouveau projet "RES3".

L'ajout du routeur 3600 se fait simplement par "glisser-déplacer". Bouton droit de la souris sur le routeur "R1". Cliquez sur l'option "Changer le nom d'hôte" ; tapez "SWR1" pour "Switch-Router 1".

Bouton droit de la souris sur le routeur "R1". Cliquez sur l'option "Changer le symbole" ; sélectionnez "label_switch_router".

Bouton droit de la souris sur le routeur "R1". Cliquez sur l'option "Configurer". Sélectionnez "SWR1". Cliquez sur l'onglet "Slots". Rubrique "slot 1", sélectionnez le module "NM-16ESW".

note Note

Un message vous indique que les liens devront se faire manuellement avec le module."NM-16ESW".

Figure 39 - RES3 - Cisco 3660 et module NM-16ESW

RES3 - Cisco 3660 et module NM-16ESW

Créez, de la même manière, le "SWR2". Créez un lien manuel entre les ports "f1/15" des deux "Switch-routers".

Figure 40 - RES3 - Lien SWR1 et SWR2

RES3 - Lien SWR1 et SWR2

5.2 - Configurer les ordinateurs "VPCS"

Configurez les huit ordinateurs "VPCS" de la manière suivante :

Tableau 1 - Ordinateurs VPCS

VPCS Valeurs
VPC1 LPort:30000 - hôte distant:127.0.0.1 - RPort : 20000
VPC2 LPort:30001 - hôte distant:127.0.0.1 - RPort : 20001
VPC3 LPort:30002 - hôte distant:127.0.0.1 - RPort : 20002
VPC4 LPort:30003 - hôte distant:127.0.0.1 - RPort : 20003
VPC5 LPort:30004 - hôte distant:127.0.0.1 - RPort : 20004
VPC6 LPort:30005 - hôte distant:127.0.0.1 - RPort : 20005
VPC7 LPort:30006 - hôte distant:127.0.0.1 - RPort : 20006
VPC8 LPort:30007 - hôte distant:127.0.0.1 - RPort : 20007

Sur le Switch-Router "SWR1", faites les liens manuels suivants :

Tableau 2 - Liens SWR1 et VPC1, VPC2, VPC3 et VPC4

VPCS Liens SWR1
 VPC1 nio_udp:30000:127.0.0.1:20000 ==> f1/0
VPC2 nio_udp:30001:127.0.0.1:20001 ==> f1/1
VPC3 nio_udp:30002:127.0.0.1:20002 ==> f1/2
VPC4 nio_udp:30003:127.0.0.1:20003 ==> f1/3

Sur le Switch-Router "SWR2", faites les liens manuels suivants :

Tableau 3 - Liens SWR2 et VPC5, VPC6, VPC7 et VPC8

VPCS Liens SWR2
 VPC5 nio_udp:30004:127.0.0.1:20004 ==> f1/0
VPC6 nio_udp:30005:127.0.0.1:20005 ==> f1/1
VPC7 nio_udp:30006:127.0.0.1:20006 ==> f1/2
VPC8 nio_udp:30007:127.0.0.1:20007 ==> f1/3

5.3 - Configurer les VLans et le Trunk

Démarrez les deux "Switch-routers". Lancez la "console" sur les deux appareils.

Figure 41 - RES3 - Consoles sur SWR1 et SWR2

RES3 - Consoles sur SWR1 et SWR2

Changez le nom "Router" du Switch-Router n° 1 en"SWR1" :

Router> en
Router# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
Router (config)# hostname SWR1
SWR1(config)# exit

Créez le "VLan 10 Ingenierie" et le "VLan 20 Commerciaux" sur "SWR1" ; affectez les ports "0 et 1" pour le "VLan 10", "2 et 3" pour le "VLan 20 :

SWR1# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR1(config)# vlan 10
SWR1(config-vlan)# name Ingenierie
SWR1(config-vlan)# exit
SWR1(config)# int range f1/0 - 1
SWR1(config-if-range)# switchport mode access
SWR1(config-if-range)# switchport access vlan 10
SWR1(config-if-range)# no shut
SWR1(config-if-range)# exit
SWR1(config)# vlan 20
SWR1(config-vlan)# name Commerciaux
SWR1(config-vlan)# exit
SWR1(config)# int range f1/2 - 3
SWR1(config-if-range)# switchport mode access
SWR1(config-if-range)# switchport access vlan 20
SWR1(config-if-range)# no shut
SWR1(config-if-range)# end

Créez un lien "taggé (trunk) sur le port "f1/15" de "SWR1" ; indiquez les VLans qui transiteront par ce lien :

SWR1# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR1(config)# int f1/15
SWR1(config-if)# switchport mode trunk
SWR1(config-if)# switchport trunk encapsulation dot1q
SWR1(config-if)# switchport trunk allowed vlan add 10,20
SWR1(config-if)# no shut
SWR1(config-if)# end

Sauvegardez la configuration de "SWR1" :

SWR1# write mem
    Building configuration...
    [OK]
SWR1# copy run start
    Destination filename [startup-config]?
    Building configuration...
    [OK]

Effectuez les mêmes manipulations avec le Switch-Router n° 2 ; "hostname" : SWR2.

Sauvegarder le projet :

Menu [Fichier] de GNS3 => [Sauvegarder]

Vérifiez l'état de vos VLans sur "SWR1" et "SWR2" :

SWR1# sh vlan-switch br
      VLan  Name                   Status    Ports
      ---- ----------------------- --------- -----------------------------
      1    default                 active    Fa1/4, Fa1/5, Fa1/6, Fa1/7
                                             Fa1/8, Fa1/9, Fa1/10, Fa1/11
                                             Fa1/12, Fa1/13, Fa1/14
      10   Ingenierie              active    Fa1/0, Fa1/1
      20   Commerciaux             active    Fa1/2, Fa1/3
      1002 fddi-default            act/unsup
      1003 token-ring-default      act/unsup
      1003 fddinet-default         act/unsup
      1005 trnet-default           act/unsup
note Note

les VLANs "1002 à 1005" sont des VLANs réservés pour les réseaux FDDI et Token Ring ; ils sont créés automatiquement. Vous ne pouvez pas les supprimer.

Vérifiez l'état du "trunk" et les VLans associés sur les deux Switch-routers :

SWR1# sh int trunk
      Port     Mode     Encapsulation  Status     Native vlan
      Fa1/15   on       802.1q         trunking   1

      Port     Vlans allowed on trunk
      Fa1/15   1-4094

      Port     Vlans allowed and active in management domain
      Fa1/15   1,10,20

      Port     Vlans in spanning tree forwarding state and not pruned
      Fa1/15   1,10,20

5.4 - Tester le fonctionnement des VLANs

Démarrez le programme "VPCS". Configurez les adresses IP pour chaque ordinateurs "VPCx".

Tableau 4 - Adressage IP des ordinateurs VPCx

VPCS Adresses IP
VPC1 - VLAN 10 IP : 192.168.10.1/24
VPC2 - VLAN 10 IP : 192.168.10.2/24
VPC3 - VLAN 20 IP : 192.168.20.1/24
VPC4 - VLAN 20 IP : 192.168.20.2/24
VPC5 - VLAN 10 IP : 192.168.10.3/24
VPC6 - VLAN 10 IP : 192.168.10.4/24
VPC7 - VLAN 20 IP : 192.168.20.3/24
VPC8 - VLAN 20 IP : 192.168.20.4/24

Sauvegardez la configuration de vos "VPCx" :

VPCS[1]> save startupres3.vpc
.........  done

À partir de l'ordinateur "VPC1", faîtes un "ping" sur le "VPC5 (192.168.10.3)" ; à partir de l'ordinateur "VPC3", faîtes un "ping" sur le "VPC8 (192.168.20.4)" :

Figure 42 - RES3 - Pings VLANs

RES3 - Pings VLANs

5.5 - Capturer une trame ICMP avec WireShark

Le logiciel "Wireshark" est un outil d'analyse des protocoles réseaux. Nous allons l'utiliser sur l'interface "f1/15" du Switch-Router "SWR1" pour visualiser les "ID" des VLANs sur le "trunk 802.1Q".

Bouton droit de la souris sur le Switch-Router "SWR1". Cliquez sur l'option "Capture". Sélectionnez le lien "f1/15 connected to SWR2 f1/15". Sélectionnez la source "SWR1 f1/15 (encapsulation:ETH)".

À partir de l'ordinateur "VPC3", faîtes un "ping" sur le "VPC8 (192.168.20.4)".

Figure 43 - RES3 - Wireshark

RES3 - Wireshark

Sélectionnez la trame "ICMP" qui correspond au "ping". l'ID: 20 doit apparaître sur la ligne "802.1Q Virtual LAN ...".

5.6 - Activer le "Spanning-Tree"

Le "Spanning-Tree" est un protocole qui permet d'éviter les boucles en désactivant les liens redondants.

Pour activez le "Spanning-Tree", tapez les commandes suivantes sur chaque "Switch-router" :

SWR1> en
SWR1# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR1(config)# spanning-tree vlan 1
SWR1(config)# spanning-tree vlan 10
SWR1(config)# spanning-tree vlan 20
SWR1(config)# end

Pour effectuer un diagnostic, tapez la commande suivante :

SWR1> en
SWR1# sh spanning-tree vlan 1
    VLAN1 is executing the ieee compatible Spanning Tree protocol
    .......................

Figure 44 - RES3 - Spanning-Tree

RES3 - Spanning-Tree

Pour désactiver le "Spanning-Tree", tapez la commande suivante :

SWR1> en
SWR1# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR1(config)# no spanning-tree
SWR1(config)# end

Figure 45 - RES3 - Configuration finale

RES3 - Configuration finale


Auteur : Stéphane Maas / 2013-2017
Précédent ACCUEIL Suivant