Partie VII. GNS3 Réseau n° 5
Précédent ACCUEIL Suivant

VII. GNS3 RÉSEAU N° 5

Vous allez créer un réseau constitué de deux routeurs. Les modules "NM-16ESW" et "NM-4T" sont installés sur les deux appareils ; ils sont reliés par les interfaces séries "s2/0" ; des ordinateurs "VPCS" complètent la topologie pour les tests de fonctionnement. "RIP Version 2" sera activé.

7.1 - Ajouter des modules dans un routeur 3600

Lancez le logiciel GNS3.

Reprenez le tutoriel "GNS3 RÉSEAU N° 1" pour créer le nouveau projet "RES5".

L'ajout d'un routeur se fait simplement par "glisser-déplacer". Bouton droit de la souris sur le routeur "R1". Cliquez sur l'option "Changer le nom d'hôte" ; tapez "SWR1" pour "Switch-Router 1".

Bouton droit de la souris sur le routeur "R1". Cliquez sur l'option "Changer le symbole" ; sélectionnez "label_switch_router".

Bouton droit de la souris sur le routeur "R1". Cliquez sur l'option "Configurer". Sélectionnez "SWR1". Cliquez sur l'onglet "Slots". Rubrique "slot 1", sélectionnez le module "NM-16ESW" ; rubrique "slot 2", sélectionnez le module "NM-4T".

note Note

Un message vous indique que les liens devront se faire manuellement avec le module."NM-16ESW".

Figure 46 - RES3 - Cisco 3660, modules NM-16ESW et NM-4T

RES3 - Cisco 3660, modules NM-16ESW et NM-4T

Créez, de la même manière, le "SWR2". Créez un lien manuel entre les ports "s2/0" des deux "Switch-routers".

Figure 48 - RES3 - Lien SWR1 et SWR2

RES3 - Lien SWR1 et SWR2

7.2 - Configurer les ordinateurs "VPCS"

Configurez les quatre ordinateurs "VPCS" de la manière suivante :

Tableau 1 - Ordinateurs VPCS

VPCS Valeurs
VPC1 LPort:30000 - hôte distant:127.0.0.1 - RPort : 20000
VPC2 LPort:30001 - hôte distant:127.0.0.1 - RPort : 20001
VPC3 LPort:30002 - hôte distant:127.0.0.1 - RPort : 20002
VPC4 LPort:30003 - hôte distant:127.0.0.1 - RPort : 20003

Sur le Switch-Router "SWR1", faites les liens manuels suivants :

Tableau 2 - Liens SWR1, VPC1 et VPC2

VPCS Liens SWR1
 VPC1 nio_udp:30000:127.0.0.1:20000 ==> f1/0
VPC2 nio_udp:30001:127.0.0.1:20001 ==> f1/1

Sur le Switch-Router "SWR2", faites les liens manuels suivants :

Tableau 3 - Liens SWR2, VPC3 et VPC4

VPCS Liens SWR2
 VPC3 nio_udp:30002:127.0.0.1:20002 ==> f1/0
VPC4 nio_udp:30003:127.0.0.1:20003 ==> f1/1

Configurez sur les ordinateurs "VPCS" les adresses IP suivantes :

Tableau 4 - Adressage IP des ordinateurs VPCx

VPCS Adresses IP
VPC1 IP : 172.16.8.1/21 - GW : 172.16.15.254
VPC2 IP : 172.16.8.2/21 - GW : 172.16.15.254
VPC3 IP : 192.168.0.1/24 - GW : 192.168.0.254
VPC4 IP : 192.168.0.2/24 - GW : 192.168.0.254

Sauvegardez la configuration de vos "VPCx" :

VPCS[1]> save startupres5.vpc
.........  done

7.3 - Configurer les Interfaces séries des routeurs

Démarrez les deux "Switch-routers". Lancez la "console" sur les deux appareils.

Changez les noms "Router" en "SWR1" et "SWR2".

Sur le premier switch-router :

Router> en
Router# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
Router (config)# hostname SWR1
SWR1(config)# exit

Sur le deuxiéme switch-router :

Router> en
Router# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
Router (config)# hostname SWR2
SWR2(config)# exit

Configurer, sur le "SWR1", l'interface "s2/0" en "DCE" et attribuez à cette interface l'adresse IP "10.0.0.254".

SWR1# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR1(config)# int serial 2/0
SWR1(config-if)# desc Connection to SWR2
SWR1(config-if)# clock rate 128000
SWR1(config-if)# ip address 10.0.0.254 255.0.0.0
SWR1(config-if)# no shut
SWR1(config-if)# end

Configurer, sur le "SWR2", l'interface "s2/0" en "DTE" et attribuez à cette interface l'adresse IP "10.0.0.253".

SWR2# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR2(config)# int serial 2/0
SWR2(config-if)# desc Connection to SWR1
SWR2(config-if)# ip address 10.0.0.253 255.0.0.0
SWR2(config-if)# no shut
SWR2(config-if)# end

Sauvegardez la configuration de "SWR1" :

SWR1# write mem
    Building configuration...
    [OK]
SWR1# copy run start
    Destination filename [startup-config]?
    Building configuration...
    [OK]

Effectuez les mêmes manipulations sur "SWR2".

Sauvegarder le projet :

Menu [Fichier] de GNS3 => [Sauvegarder]

Vérifiez le lien entre "SWR1" et "SWR2" par un "ping" sur l'adresse IP.

7.4 - Configurer une adresse IP sur le VLAN administration

Attribuez l'adresse IP "172.16.15.254" et le masque "255.255.248.0" sur le "VLAN 1" d'administration de "SWR1" :

SWR1# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR1(config)# int vlan 1
SWR1(config-if)# ip address 172.16.15.254 255.255.248.0
SWR1(config-if)# no shut
SWR1(config-if)# end

Attribuez l'adresse IP "192.168.0.254" et le masque "255.255.255.0" sur le "VLAN 1" d'administration de "SWR2" :

SWR2# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR2(config)# int vlan 1
SWR2(config-if)# ip address 192.168.0.254 255.255.255.0
SWR2(config-if)# no shut
SWR2(config-if)# end

7.5 - Configurer "RIP" Version 2 sur des routeurs

RIP est un protocole d'information de routage qui permet de communiquer, aux autres routeurs, la distance qui les sépare d'un autre réseau. Cette distance ce mesure en nombre de sauts ("hops" en anglais).

La configuration de "RIP v2" sur un matériel Cisco consiste à l'activer puis à lui indiquer les réseaux que l'on souhaite propager.

Sur "SWR1", tapez les commandes suivantes :

SWR1# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR1(config)# router rip
SWR1(config-router)# version 2
SWR1(config-router)# network 10.0.0.0
SWR1(config-router)# network 172.16.8.0
SWR1(config-router)# no auto-summary
SWR1(config-router)# end

Sur "SWR2", tapez les commandes suivantes :

SWR2# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
SWR2(config)# router rip
SWR2(config-router)# version 2
SWR2(config-router)# network 10.0.0.0
SWR2(config-router)# network 192.168.0.0
SWR2(config-router)# no auto-summary
SWR2(config-router)# end

Pour visualiser le fonctionnement de "RIP" sur "SWR1", tapez la commande :

SWR1# sh ip route

Figure 52 - RES5 - Routes sur SWR1

RES5 - Routes sur SWR1

Pour visualiser le fonctionnement de "RIP" sur "SWR2", tapez la commande :

SWR2# sh ip route

Figure 53 - RES5 - Routes sur SWR2

RES5 - Routes sur SWR2

Avez-vous remarqué l'initial "R" pour "RIP" ?

7.6 - Tester le fonctionnement du réseau avec "Tracert"

"Tracert" est un outil qui permet de suivre les chemins qu'un paquet IP va emprunter pour aller d'un ordinateur A à un ordinateur B.

À partir de l'ordinateur "VPC1", tapez la commande suivante : tracert 192.168.0.1.

Figure 54 - RES5 - Tracert

RES5 - Tracert

Vous visualisez ici, le chemin qu'utilise "VPC1" pour communiquer avec "VPC3".

Figure 51 - RES5 - Configuration finale

RES5 - Configuration finale

Auteur : Stéphane Maas / 2013-2016
Précédent ACCUEIL Suivant